SU fuel pump, only clicking once.

Discuss Electrical problems here.
Forum rules
By using this site, you agree to our rules. Please see: Terms of Use
Post Reply
shedthestate
Minor Friendly
Posts: 17
Joined: Tue Dec 19, 2023 5:55 pm
Location: Truro/Falmouth, Cornwall, UK
MMOC Member: No

SU fuel pump, only clicking once.

Post by shedthestate »

Hi All
Not working on a Morris today, but a 1930s Guy Motors truck.
It has a new, SU pump, that has suddenly stopped working.
I clicks once, when a voltage is applied, but that's it. No tick, tick, tick, etc.

Any ideas?
Last edited by shedthestate on Wed Jan 31, 2024 11:01 am, edited 1 time in total.
svenedin
Minor Legend
Posts: 1619
Joined: Fri Aug 29, 2014 9:27 am
Location: Surrey
MMOC Member: Yes

Re: SS fuel pump, only clicking once.

Post by svenedin »

Is this points or electronic type SU fuel pump? I was thinking SS in the thread title is sold-state so the electronic variant?

There was a very recent thread about this. It turned out to be the circuit board. viewtopic.php?t=49840&start=20

Common problems with pumps are a blocked built-in filter (unscrew and clean), poor electrical connections, diaphragm gummed up with sticky fuel (remove filter and spray carburettor cleaner inside, give a good shake). Also consider whether the inlet fuel line from tank to pump may be blocked.

If it's a points pump then clean the points. If brand new there is usually a protective coating on the points to prevent corrosion in storage. Clean this off with switch cleaner or petrol. Kitchen paper is good for this as it is a bit abrasive.

Stephen
1969 1098cc Convertible “Xavier” which I have owned since 1989.

Stephen
shedthestate
Minor Friendly
Posts: 17
Joined: Tue Dec 19, 2023 5:55 pm
Location: Truro/Falmouth, Cornwall, UK
MMOC Member: No

Re: SU fuel pump, only clicking once.

Post by shedthestate »

Thanks Stephen
Sorry. Trying to do this on my phone with my fat fingers.
It is a points pump, not solid state.
I will have a look at the thread you posted.
Paul
User avatar
geoberni
Minor Legend
Posts: 3512
Joined: Fri Aug 04, 2017 11:19 am
Location: North Leicestershire
MMOC Member: Yes

Re: SU fuel pump, only clicking once.

Post by geoberni »

shedthestate wrote: Wed Jan 31, 2024 10:24 am It has a new, SU pump, that has suddenly stopped working.
I clicks once, when a voltage is applied, but that's it. No tick, tick, tick, etc.
Further detail required.
New as it fitted in the last few weeks, or just fitted today and it's only clicking once every time power applied ?

If it's new today, clean the points.
If it's had some use, still clean the points, as setting it up from scratch requires opening it up.

I don't suppose the Float Chamber on the carb is full?
A brand new pump on a full carb, might only click once as it'll have zero leakage back past the NRV.
One click and it can't move any further because of the fuel pressure in the output line.
Basil the 1955 series II

Image
shedthestate
Minor Friendly
Posts: 17
Joined: Tue Dec 19, 2023 5:55 pm
Location: Truro/Falmouth, Cornwall, UK
MMOC Member: No

Re: SU fuel pump, only clicking once.

Post by shedthestate »

It is a new pump, that was fitted a year or so ago, but the vehicle ie very rarely used.
We moved the vehicle out into the yard to move another in. The next day, went the start the Guy, and it wouldn't run.
Post Reply